SPCascadeDropdowns and the Content Types

Sep 8, 2010 at 8:08 AM

When you use the content types of document libraries, it doesn´t work!
The ChildColumn always has the choice of "None", even if is a required column.
Does anyone know how to fix this or what I can do?

Thanks!

Coordinator
Sep 8, 2010 at 3:18 PM

duru:

SPCascadeDropdowns sohlud work with Content Types just fine. It may be that the column names are different in each Content Type. You should check that.

M.

Sep 9, 2010 at 7:17 AM
Edited Sep 9, 2010 at 7:31 AM

Thanks.

I explained badly.
First of all, ParentColumn and ChildColumn are SiteColumns, so the columns can be used in other lists.
The dropdowlist gives me back the options correctly, the problem is that the first option is "Choose (0)", even if it is a required field.
Then I save and I get an unexpected error, because it is a required field and it hasn´t value.

Coordinator
Sep 9, 2010 at 11:25 AM

Can you paste the call you are making to SPCascadeDropdowns here?

M.

Sep 9, 2010 at 4:42 PM

Of course, i can paste it here.

<script language="javascript" src="/funcionalidades/jquery-1.4.2.min.js" type="text/javascript"></script>
<script language="javascript" src="/funcionalidades/jquery.SPServices-0.5.6.min.js" type="text/javascript"></script>
<script type="text/javascript">
   $(document).ready(function()
   {
        $().SPServices.SPCascadeDropdowns({
            relationshipWebURL: "/",
            relationshipList: "Subprocesos",
            relationshipListParentColumn: "Proceso",
            relationshipListChildColumn: "Title",
            parentColumn: "Proceso",
            childColumn: "Subproceso",
            debug: true
        });
    });
</script>

Coordinator
Sep 10, 2010 at 3:11 AM

I think setting the promptText option to an empty string ought to solve this.

   promptText: "Choose {0}...",  // [Optional] Text to use as prompt. If included, {0} will be replaced with the value of childColumn

M

Sep 10, 2010 at 7:54 AM

Good morning sympmarc.

It´s working perfectly.

Thank you very much.

Coordinator
Sep 10, 2010 at 11:31 AM

Excellent!

M.