SPServices Search and Timeout error

Oct 11, 2011 at 8:30 AM

Hi,

I'm using Content Editor Web Part in MOSS 2007 and jQuery SPServices to get some items from the News Search scope. Everything is working and displaying but sometime I'm getting ERROR_SERVER - System.ServiceProcess.TimeoutException:

<responsepacket xmlns="urn:Microsoft.Search.Response">
   <response domain="QDomain">
      <status>ERROR_SERVER</status>
      <debugerrormessage>System.ServiceProcess.TimeoutException</debugerrormessage>
   </response>
</responsepacket>

Is there any way to avoid getting this error, e.g. increase time connection? Here is my code:

$().SPServices({
        operation: "Query",
        async: true,
        queryXml: getQueryRecentNewsXml(maxRecentNewsArticles),
        debug: false,
        completefunc: function (xData, Status) {

            if (Status != "success") {
                displayNewsErrorMessage();
                return;
            }

            var queryResult = $(xData.responseXML).find("QueryResult").text();
            var xml = $("<xml>" + queryResult + "</xml>");
            var queryStatus = xml.find("Status").text();

            if (queryStatus != "SUCCESS") {
                displayNewsErrorMessage(queryResult.toString());
            } else {
                // binds recent news                    
                populateRecentNewsLinks(getRecentItemsFromXml(xml));
            }
        }
    });

 

Thanks for your help!

Gosia


Coordinator
Oct 12, 2011 at 12:06 AM
Gosia:

I haven't seen this type of timeout before. It's got to be between the Web Service and the Search service, so I don't think there's anything you can pass in to fix it. You'll probably need to look at the ULS logs with your admin.

M.
>
Apr 16, 2014 at 12:19 PM
Hi Gosia:

I encounter the same problem as you ,and I'm very confused.Could you please tell me how you solved the problem?

Thank you very much
Elaine