permissions to use spservices

Nov 28, 2011 at 12:48 PM

sharepoint foundation,

have given specific users contribute and user permissions.

however when they navigate to a page that uses spservices, they get nothing displayed.

What permissions do i need to give them?

I am currently in as a site collection admin, and have no issues.

Coordinator
Nov 28, 2011 at 1:03 PM
devforge:

Make sure your users also have read permissions on the .js files, wherever you have stored them.

M.
Nov 28, 2011 at 1:27 PM

Hi Marc,

placed both js and css in Style Library\css and \js respectively.

You are correct , as soon as I gave explicit ppl Style Library permissions, it worked.

Know of an easy way i can give "Authenticated domain" users access to the Style Library .. library?

Thanks much for this...

 

Nov 28, 2011 at 1:36 PM

Either create a new group called All Users or use the Style Resource Readers group.  Go into add users to the group and you'll see a link to add all authenticated users, click that and ensure they have read permission.  Then go to the Style Library and make sure either the All Users or Style Resource Readers have read permission.

Also you'll want to make sure that the files stored in the Style Library are checked in and approved if the library is configured for versioning.

Nov 28, 2011 at 2:49 PM

Thanks Eric,

However I must say, unless I understood wrong, I am trying to get away with simply giving read permission (even tried adding SOAP WebDav access to Restricted Read), however/sadly I can only get it to work (for other users) with the "Contribute" permission, on the style library list.

Not sure why - I would attach a pic of the permission levels if i could; still I appreciate the help you guys have given me.

Coordinator
Nov 28, 2011 at 3:27 PM

devforge:

If you give the pseudo-user NT Authority\authenticated users read access, then everyone who is logged in will have access.

M.