SPCascadeDropdowns function

Dec 6, 2011 at 5:18 PM

I am trying to use the SPCascadeDropdowns function and am having some issues. 

I read the instructions at the location below and believed I followed them perfectly, but I am getting an error:

http://spservices.codeplex.com/wikipage?title=$().SPServices.SPCascadeDropdowns&referringTitle=Documentation

The error is

 

Line: 978

Char: 2

Error: Object Expected

URL: Path to the library I am in.

 

I copied the 2 files on the Download tab into a library at the top of my site collection. 

I added a HTML Web Editor Web Part on the Add Document Form page:

<script language="javascript" type="text/javascript"

src="https://ishare.isgn.com/jQueryLibrary/jquery-1.4.2.js"></script>
<script language="javascript" type="text/javascript"

src="https://ishare.isgn.com/jQueryLibrary/jquery.SPServices-0.5.7.min.js"></script>
<script language="javascript" type="text/javascript">
 $(document).ready(function() {
  $().SPServices.SPCascadeDropdowns({
   relationshipList: "DocTypes",
   relationshipListParentColumn: "DocCategory",
   relationshipListChildColumn: "Title",
   parentColumn: "DocCategory",
   childColumn: "DocType",
   debug: true
  });
  $().SPServices.SPCascadeDropdowns({
   relationshipList: "DocCategoriesTypes",
   relationshipListParentColumn: "Region_x0020_Name",
   relationshipListChildColumn: "Title",
   relationshipListSortColumn: "ID",
   parentColumn: "DocType",
   childColumn: "Title"
  });
 });
</script>CAMLQuery: "<Eq><FieldRef Name='Status'/><Value Type='Text'>Active</Value>

Coordinator
Dec 8, 2011 at 12:37 PM

Corinne:

I think it's probably that the references to one or both of the .js files isn't correct.

M.

Dec 9, 2011 at 3:39 PM

You were right. What a silly mistake. I am trying to do too many things!

Thanks!

Corinne


From: sympmarc [email removed]
Sent: Thursday, December 08, 2011 8:38 AM
To: Corinne Seagrave
Subject: Re: SPCascadeDropdowns function [SPServices:282007]

From: sympmarc

Corinne:

I think it's probably that the references to one or both of the .js files isn't correct.

M.