SPSetMultiSelectSizes and SPFilterDropdown work incorrectly together

Dec 21, 2011 at 6:27 AM

In my case, I called both SPSetMultiSelectSizes and SPFilterDropdown functions on a multi-select lookup column in MOSS2007(JQuery1.7 and SPServices0.7.0), however ,

if I call SPSetMultiSelectSizes before SPFilterDropdown, there will show a error in debug mode saying cannot find the lookup column.

if I call SPSetMultiSelectSizes after SPFilterDropdown, there will be no error message showing up, but the "possible values" select control will show a grey panel(I am using IE7). is there anyone who also met this problem? 

Coordinator
Dec 30, 2011 at 3:02 PM

onwind:

I can't seem to reproduce this in my environment. Does each function call work correctly independently?

M.

Jan 4, 2012 at 1:32 AM
Yes, they work correctly independently.


From: [email removed]
To: [email removed]
Date: Fri, 30 Dec 2011 08:02:33 -0800
Subject: Re: SPSetMultiSelectSizes and SPFilterDropdown work incorrectly together [SPServices:283702]

From: sympmarc
onwind:
I can't seem to reproduce this in my environment. Does each function call work correctly independently?
M.
Read the full discussion online.
To add a post to this discussion, reply to this email (SPServices@discussions.codeplex.com)
To start a new discussion for this project, email SPServices@discussions.codeplex.com
You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.
Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com
Coordinator
Jan 4, 2012 at 2:57 PM

Ok, I'm not sure what's going on, then. Can you post your script?

M.