SPSetMultiSelectSizes maxWidth problem

Jul 10, 2012 at 10:35 AM


I tried to fix the width without success. Here is my code:

	$(document).ready(function() {
	    multiSelectColumn: "ColumnName", 
	    minWidth: 100,
	    maxWidth: 200

No matter what value I put on maxWidth and minWidth, Width is getting the maximum value from the column.

Any help is highly appreciated.

Thanks, Ovidiu

Jul 10, 2012 at 12:03 PM


Can you explain what you'd like to happen? Do you want the width to be set to 200px regardless what the contents of the multi-select is?


Jul 10, 2012 at 12:22 PM
Edited Jul 11, 2012 at 9:37 AM

Hi Marc,

Yes, I want to have the width between 100px and 200px, no matter what is the size of content.

I use this in a newForm, and I want to control the width of the form.

Thanks for your answer,


Width is getting the maximum value from the content of the multi-select, only with jquery.SPServices-0.7.1a

If I use jquery.SPServices-0.7.2ALPHA6, it doesn't change the width of control.

Using jquery-1.7.2.min.js

Jul 12, 2012 at 1:37 AM

I just tested with  jquery.SPServices-0.7.2ALPHA7, which works fine in my WSS test environment, as does jquery.SPServices-0.7.1a.min.js. In both cases, with the options set as:

    multiSelectColumn: "Web Service Operation",
    minWidth: 100,
    maxWidth: 200

the left and right boxes are set to 200px, which I measured with the Developer Tools. The measurement does inclode the right side scrollbar.

Are you doing anything else in the form? Custom branding or other script?


Jul 12, 2012 at 6:48 AM

I have a custom newForm, which was created in SPD 2010, by following regular steps of creating a new Form.

There is nothing customized.

In this form, I have two fields for which I want to use SPSetMultiSelectSizes.

And I use jquery.SPServices-0.7.2ALPHA6, not jquery.SPServices-0.7.2ALPHA7 like you.

I think you have a newest version which is not published yet :)



Jul 12, 2012 at 1:22 PM

Yes, I have a newer alpha. but the function hasn't changed for quite a while. Since you've customized the form, your markup may well be different.