Cascading Dropdown Error

Oct 11, 2012 at 10:13 PM

Evening All

I have hit the same error on a SharePoint 2010 Enterprise and a MOSS implementation. The cascade works as expected but when I attempt to save the form, the data does not commit and I get the standard Error page with troubleshooting.  I added a new button (for testing) to the form with a simple _commit command and recieved the same error. 

When the code is removed, the forms saves as expected.

For the 2010 implementation, the code was added via a content editor webpart.(I know it is not recommended) but did not have Designer available at the time I added to script.  For the MOSS Implmentation, I added the code as recommended in the documentation.

Both Custom forms were created via the standard processes recommended with SharePoint Designer.  Versions of SPServices and JQuery are indicated in the script.  I have stared at the code for an hour and cannot see anything wrong..     Does anyone have a suggestion or thought?  I expect this to be a V8 moment...  but wanted to ask..  Thanks in advance.

<script type="text/javascript" language="javascript" src="/GregTest/jQuery/jquery-1.8.2.min.js"></script>
<script type="text/javascript" language="javascript" src="/GregTest/jQuery/jquery.SPServices-0.7.2.min.js"></script>

<script type="text/javascript">
    $(document).ready(function() {
            relationshipList: "LOBS",
            relationshipListParentColumn: "Division",
            relationshipListChildColumn: "Title",
            parentColumn: "Division",
            childColumn: "LineofBusiness"


Oct 12, 2012 at 1:44 PM

If you're getting an error on commit but the cascading is working as you'd expect, then I suspect that there's an issue with how you've got your lists set up. If the Division and LineOfBusiness columns aren't lookups to the LOBS and whatever you've called your Divisions list, then you'll likely get gross errors due to value mismatches.


Oct 12, 2012 at 7:56 PM


I told you..  a V8 moment.  The childcolumn was setup a a choice and not lookup.  I missed that in the documentation and of course it was there.
Thank you for the quick response and awesome work!


Oct 12, 2012 at 8:13 PM

You bet. Glad you got it working!