xData.responseText showing no error code or undefined with no list interaction occurring

Dec 14, 2012 at 5:38 PM
Edited Dec 14, 2012 at 7:37 PM

Hi,

This seems like it should be very simple. I have poured over the documentation, looked at examples and had a previously working UpdateListItems operation from a feedback form. I revisit this a year later and now it no longer works. A few items

  • when I use a newer Jquery such as 1.8 or SP Services 7.2 my xData response text comes up as undefined
  • Running WSS 3.0
  • When using the below library versions I get error code 0x0000000; which is no error, but no items are created
  • I have an older deprecated batch process in a SOAP call which does work, BUT, that it works intermittently so I figured modermizing to the value pairs and SP services would behave more relaibly.

 

<script type="text/javascript" src="/js/jquery-1.3.2.js"></script>
<script type="text/javascript" src="/js/jquery.SPServices-0.5.7.js"></script>

<script>
                            
         //SP Services Method
             $(document).ready(function() {
                 $("#newTaskButton").click(function() {
                  var url = "test";               

                  CreateNewItem(url);

                 });
           });
          function CreateNewItem(url) {
             $().SPServices({
                 operation: "UpdateListItems",
                 async: false,
                 batchCmd: "New",
                 webURL: "sss/sites/web",
                 listName: "Contact",
                valuepairs: [["URL", url]],
                 completefunc: function(xData, Status) {
            alert(xData.responseText);
                     }
               });}

          
                    </script>

Coordinator
Dec 14, 2012 at 5:48 PM

It seems like you are doing things correctly. I'd recommend upgrading to SPService 0.7.2 and jQuery 1.8.x, for sure.

Are you sure that you have a value for url when you call CreateNewItem?

M.

Dec 14, 2012 at 7:36 PM

Hi Marc,

 

Thanks for the quick reply. You truly are a shepard, we would be lost without your guidance and expertise. I did update to 1.8.0 and 7.2; now the xData response shows undefined. I also even made the url variable just a hardcoded text string to be sure for testing ( I edited the original code to reflect that). Still no result. Could the web application owner be locking SOAP calls / interactions?

Since it appears I am stuck, and I love what you have done, are there any other competing services / libraries which can replicate this functionality? Prefer to not use them but I seem to have hit a roadblock at this point.

Coordinator
Dec 14, 2012 at 7:41 PM

I'd suggest checking the network traffic with Firebug or Fiddler. What you're doing ought to work, but it could be a number or different things going wrong. For instance, make sure that your listName and webURL are correct.

M.

Dec 17, 2012 at 10:22 PM

Just a follow up Marc. This is very bizarre. I moved the page to a different server (which should not matter as I successfully use GetListItems there anyway). But in the new location I now get a error code 0x81020020 Invalid URL parameter. So like you say it must be with the site name. This site name is the exact same one I successfully use with GetListItems. Fiddler confirmed the name / lists / traffic.

 I am going to try and create a list elsewhere and report back to you what the fix was in case I can solve it.

Coordinator
Dec 18, 2012 at 4:40 AM
Edited Dec 19, 2012 at 4:41 AM

Looking at what you originally posted above, shouldn't the webURL be:

webURL: "/sss/sites/web",

? Note the leading slash.

M.

Dec 18, 2012 at 6:49 PM

You are correct Mark! I was using the absolute href before in the URL: properties. I'm not sure but maybe the newer Jquery & SP Services versions changed that from before? Thats the only reason I'm  thinking it previously worked and no longer does. That would explain the error code 0x81020020.

never ceases to amaze me that the smallest details are the most important...

Coordinator
Dec 19, 2012 at 4:42 AM

It shouldn't have ever worked without the leading slash unless the relative path was different. In any case, glad it's working now.

M.