SPAutoComplete not working

Aug 2, 2013 at 9:01 AM
Edited Aug 2, 2013 at 9:02 AM
I'm really new in javasript and can't figure out why small test example doesn't working.
All I want is autofilling one of text boxes on NewForm.
There is my code:
<script language="javascript" type="text/javascript" src=""></script>
<script language="javascript" type="text/javascript" src=""></script>

<script language="javascript" type="text/javascript">
    $(document).ready(function() {
            sourceList: "{78763E22-1EBA-44E2-B691-CE6B3570264A}",
            sourceColumn: "Theme",
            columnName: "Theme",
            ignoreCase: true,
            numChars: 3,
            slideDownSpeed: 1000,
            debug: true
When I trying write something in that textbox nothing happened and I saw error at browser console (I use last version of Chrome):
POST 500 (Internal Server Error) jquery-1.10.2.js:8706
send jquery-1.10.2.js:8706
jQuery.extend.ajax jquery-1.10.2.js:8136
$.fn.SPServices jquery.SPServices-2013.01.js:1216
(anonymous function) jquery.SPServices-2013.01.js:3191
jQuery.event.dispatch jquery-1.10.2.js:5095
elemData.handle jquery-1.10.2.js:4766
What I can do to fix this?

Thanks for your time
Aug 2, 2013 at 10:43 PM
Looks like SP did not like the request. If you look at the XML response, you may actually see the error returned (not that it will help - probably)

Try using the actual list name, not the UID.


Sent from mobile device.

Aug 5, 2013 at 8:43 AM
I found the problem.
I always forgot that when we rename some element in Sharepoint, internal name of that element stay same. I rename this field, but his internal name not renamed. So SP tried to request field that doesn't exist.
I changed "sourceColumn" and now it's working perfectly.