SPServices Cascading drop down IE Issue

Oct 14, 2013 at 8:54 AM
Just a quick question please?

When I try to have three drop downs on a page (Top one controlling second,Second controlling third) and use it in IE the third drop down will not cascade.

After looking at the IE console I get the following issue.


SCRIPT5022: NoModificationAllowedError

Any thoughts?

I am currently using IE10


Thanks

Jamlow
Oct 15, 2013 at 9:50 AM
Bump** any thoughts on the above anyone?
Oct 15, 2013 at 10:22 AM
In cases like this, it is much easier if we had code to look at. It may be that your field names are not correct or a typo or something.

Dan
Oct 15, 2013 at 10:27 AM
Thanks for the reply.

Im not sure if this is the case as it works perfectly well in Firefox and Chrome.

Any other thoughts?
$(document).ready(function() {

$().SPServices.SPCascadeDropdowns({
relationshipWebURL: "/",
    relationshipList: "Business Units",                
    relationshipListParentColumn: "Business_x0020_Area",
    relationshipListChildColumn: "Title",
    parentColumn: "Business Area",
    childColumn: "Business Unit",
    completefunc: function() {
      console.log("Cascade called")
  },
  debug:true
});

 $().SPServices.SPCascadeDropdowns({
         relationshipWebURL: "/",
    relationshipList: "Functions",                 
    relationshipListParentColumn: "Business_x0020_Unit",
    relationshipListChildColumn: "Title",
    parentColumn: "Business Unit",
    childColumn: "Function",
    completefunc: function() {
      console.log("Cascade called")
  },
  debug:true
});
});
Coordinator
Oct 15, 2013 at 4:27 PM
If it works in Chrome and Firefox, it should work in IE. However, console.log won't work in all situations in IE, and that is probably what is throwing the error. Avoid using console.log.

M.
Oct 16, 2013 at 9:16 AM
Thanks for your help but removing the console.log doesn't make it work. Could it be a browser compatibility issue?

The full error I am getting is

SCRIPT5022: NoModificationAllowedError
core.debug.js, line 5690 character 5

line 5690 from above lookes like this
opt.outerHTML = strOptHtml;

Below are my script references
<script type="text/javascript" src="../../SiteAssets/jquery-1.8.3.js"></script>
<script type="text/javascript" src="../../SiteAssets/jquery.SPServices-2013.01.js"></script>

Do you have any other ideas?

Thanks again,

Jamlow
Coordinator
Oct 16, 2013 at 1:00 PM
The error is in SharePoint's core.js, so I'm not sure what's happening. Do you see the error if you remove the SPServices stuff?

M.
Oct 16, 2013 at 1:27 PM
No I don't see the error without the SPServices. The strange thing is that it doesn't happen on the first filtered drop down but the second and in IE only. Its a tricky one really as the software solution is only going to be used in IE.

The same IE error was happening in this thread. (Last Post).
https://spservices.codeplex.com/discussions/446600

Any other recommendations?

Thanks,

Jamlow
Coordinator
Oct 16, 2013 at 1:32 PM
Are both the Business Units and Functions list stored in the root site? Can you look at the Net traffic and see what the ajaxURL (line 424 or so) is in each call? Does it work properly with SPServices v0.7.2?

M.
Oct 16, 2013 at 3:00 PM
Yes Business Units and Functions lists are stored in the root site.
It does work properly with SPServices v0.7.2.

Im not quite sure what you mean with the below. Can you guide me please? With IE im assuming?
"Can you look at the Net traffic and see what the ajaxURL (line 424 or so) is in each call"

Thanks again
Oct 16, 2013 at 3:06 PM
Im not sure if this is what you mean but I have opened the network tab on IE. Clicked start capturing and tried to use the drop down lists. When I use the first drop down list runs an event with the following result

URL Method Result Type Received Taken Initiator Wait‎‎ Start‎‎ Request‎‎ Response‎‎ Cache read‎‎ Gap‎‎
/_vti_bin/Lists.asmx POST 200 text/xml 3.55 KB 125 ms XMLHttpRequest 3511582 0 0 125 0 0

When I select an option from the second dropdown list nothing happens.

The original error in the console mentioned earlier only happens once.

Thanks,

Jamie
Coordinator
Oct 16, 2013 at 3:13 PM
Could you do me a favor and try the latest alpha I've posted?
https://spservices.codeplex.com/releases/view/104652

Clearly there's a bug here, but I may have already fixed it.

The IE Developer Tools network capture is pretty rough. If you have Firefox and Firebug, the Net tab shows more useful info. What I'm trying to figure out is what context the call is made in, e.g., http://_vti_bin/Lists.asmx vs. http://sitename/_vti_bin/Lists.asmx

M.
Oct 16, 2013 at 3:25 PM
Ill try the alpha now.

The AJAX post is to the following location http://sitename/_vti_bin/Lists.asmx. Im not sure where you mean here "ajaxURL (line 424 or so)"

Thanks,

Jamie
Coordinator
Oct 16, 2013 at 3:29 PM
Jamie:

I was giving you the line (more or less) where I build the URL to use in calling the operation. You can see it there by stepping through the script or by looking at the Net traffic.

M.
Oct 16, 2013 at 3:46 PM
Apologies, its been a long day. When I step through the code after choosing from the first dropdown the post is run twice and the ajax url on both is

"/_vti_bin/Lists.asmx"

When I do the same but select an option from the second drop down the post is run once and the ajax url is also the same.

When I use the net tab in ie the post happens only once if I choose the top drop down. If I choose the second drop down it doesn't run at all.

Does this help at all?

Thanks,

Jamlow
Coordinator
Oct 16, 2013 at 3:52 PM
Getting there. Did the alpha work?

M.
Oct 16, 2013 at 3:57 PM
Afraid not. It still worked with Chrome but not IE

Thanks,

Jamlow
Coordinator
Oct 16, 2013 at 4:02 PM
Hmm. Can you copy out the traffic from either IE or Firebug and send it to me at marc dot anderson @ sympraxisconsulting dot com? I'm having a tough time picturing what's happening in the traffic. Something isn't right.

M.
Oct 17, 2013 at 9:15 AM
Hi,

Apologies but how do I go about getting all of the traffic from Firebug?

Thanks,

jamlow
Oct 18, 2013 at 2:39 AM
Edited Oct 18, 2013 at 2:39 AM
Not sure if this is pertinent. Just Started using SPServices with Office365/SharePoint Online so I'm behind in the discussion thread. I was also having a dropdown problem.

In IE10/Win7/Jquery 1.10.2/Spservices 2013.01 when I left "relationshipWebURL" blank the form threw an error related to an undefined HTML URL. I found that the variable "ajaxURL" in SPServices (line 422+) was set to "//_vti_bin/Lists.asmx". It probably should not have the leading double slash. So I specified the "relationshipWebURL" to be the correct WebURL without the trailing slash,
relationshipWebURL: "https://website.sharepoint.com",
then cascade dropdown worked.
Oct 18, 2013 at 9:09 AM
Thanks for the help mjohnston9. I tried that but no joy :(

Jamlow
Dec 9, 2013 at 8:18 PM
Did anyone find a solution to this? After struggling for a while I got my cascading dropdowns working beautifully in Chrome and Firefox. And not so beautifully in IE 9 (or any version) when having just two dropdowns. Having three dropdowns causes the same error as described above, SCRIPT5022: NoModificationAllowedError
core.debug.js, line 5690 character 5.

Since it works in Chrome and Firefox it seems like my code is ok. I'm using the latest SPServices and jquery 10.1.2.min.

Thanks!
Helena
Coordinator
Dec 10, 2013 at 3:55 PM
I haven't been able to reproduce this. Any info you can share would be helpful.

What version of SharePoint are you running?

M.
Dec 12, 2013 at 4:33 AM
Hi Marc,

I too am experiencing this with IE 10. Works perfectly fine with Firefox. I tried adding the relationshipWebURL as suggested by another user but that didn't help me.

I am using SP 2010 Foundation. Happy to provide any further information that will help you.
Dec 17, 2013 at 11:55 PM
Hi Marc,

Just thought I should mention that my issue was related to 20+ items. Just added the following to my code before the cascading columns- like below - and this worked for me :-) May help someone else.
$().SPServices.SPComplexToSimpleDropdown({
    columnName: "Asset",
    completefunc: null,
    debug: true
    });

$().SPServices.SPCascadeDropdowns({
    relationshipList: "Assets",
    relationshipListParentColumn: "Asset",
    relationshipListChildColumn: "Description",
    parentColumn: "Asset",
    childColumn: "Description",
    debug: true
    });
Mar 12, 2014 at 8:23 PM
Still for me it is not working.... Not sure if any fix for IE????? Any one help me please
Coordinator
Mar 12, 2014 at 8:25 PM
sandy143:

What does "not working" mean in your case? What versions are you using? What are you trying to do?

It's best to start a new thread rather than pasting onto an old one.

M.
Mar 13, 2014 at 4:20 PM
Hi ,

for me Cascading is not working after CU Update.
I tried taking the latest script jquery.SPServices-2014.01 and jquery-1.11.0.min however still it is not working with reqruied fields.

Is this correct which i have used.
Coordinator
Mar 13, 2014 at 4:35 PM
jquery.SPServices-2014.01 is supposed to have a fix to handle the recent changes to the title attribute in Office365 and SharePoint 2010 with the December 2013 CU. See:
http://sympmarc.com/2014/01/23/office-365-update-changes-display-name-on-required-fields/

If it isn't working for you, please start a new thread with more specifics.

M.