SPServices Cascading Dropdown not working

Nov 5, 2013 at 5:19 PM
Edited Nov 5, 2013 at 5:20 PM
I've spent the better part of 2 day's trying to get the Cascading Drop downs to work. I was able to use the Country/Region/State example and implement and it worked perfectly. However, my lists would never work correctly. Here is an example of my data:

  1. Pre-Award
  2. Award
Market Research Document       Pre-Award
Other                                                  Pre-Award
Source List                                       Award
Solicitation Selection                    Award
Notice to Proceed               Market Research Document
Modification                          Market Research Document
Contract Audit                      Source List Document
Other                                       Source List
Every time I would run the code my SubSection drop down would correctly based on the Section Selection. However, my document type would never work. No error was thrown or anything. So after 2 days, I figured out that if there are multiple spaces in the text, it would not work. I decided to put underscores "_" to see if that would work and surprisingly it did.

I'm not sure if this is a bug with the SPServices.CascadingDropdown or not, but wanted to pass along incase someone else was having the same issues as I was having.
Nov 6, 2013 at 1:40 PM
It sounds like you weren't using the InternalName for relationshipListParentColumn or relationshipListChildColumn. If you had turned on debug mode, you should have gotten an error message. InternalNames have certain character, like spaces, encoded thusly:

DisplayName: "Document Type"
InternalName: "Document_x0020_Type"

Nov 6, 2013 at 1:58 PM
Mark - I was actually using the Internal Name of the fields. The data represented above were the actual records. I purposefully made sure that my column names and list names did not contain any spaces.

I actually had the debug set to true. It would not error out when I had records with a bunch of spaces. I would go in, change one of the relationshipList fields to something that did not exist and it would return an error as expected. But as soon as I added the underscores the cascade worked.

For example, one of the records had the following as a value that was to be populated into my 3rd cascading drop down:

"1.2.1 Request for Information (RFI)/Sources Sought/Pre-Solicitation Conference(FAR 10.002)"

So I'm not sure if the special characters were causing issues or if it was something else.
Nov 6, 2013 at 2:01 PM
So was it a column name issue or a data issue? I'm a little lost.

Nov 6, 2013 at 2:07 PM
It was a Data issue. The Columns were all set up correctly with no issues. Below are my calls and they all work now.

As I noted above, once I added the underscores to all of the data, it started functioning correctly. So the above now looks like "1.2.1__Request_for_Information_(RFI)/Sources_Sought/Pre-Solicitation_Conference(FAR_10.002)" with the underscores. It now works as intended, but only once I added the underscores to the data.
<script   type="text/javascript">
    $(document).ready(function() {
            relationshipList: "ContractSubSection",
            relationshipListParentColumn: "ContractSection",
            relationshipListChildColumn: "Title",
            parentColumn: "ContractSection",
            childColumn: "ContractSubSection",
            simpleChild: true,
            debug: true

            relationshipList: "ContractDocumentType",
            relationshipListParentColumn: "ContractSubSection",
            relationshipListChildColumn: "Title",
            parentColumn: "ContractSubSection",
            childColumn: "ContractDocumentType",
            simpleChild: true,
            debug: true
Nov 6, 2013 at 2:10 PM
OK, that shouldn't be the case. What versions of jQuery, SPServices, and browser are you using? Would you be willing to send me the relationshipList data so that I can try to recreate?

Nov 6, 2013 at 2:36 PM
Do you have an e-mail address I can send it to?
Nov 6, 2013 at 2:39 PM
marc dot anderson at sympraxisconsulting.com

Nov 8, 2013 at 12:04 PM
Mark - Not sure what you've looked at, but I think the problem may have been a double space "1.1.1 Something goes here" in the data. I just replaced all my underscores back to spaces. Then I removed the double spaces between the WBS number and the text. It appears to be working now.
Nov 8, 2013 at 1:07 PM
Interesting. I have it mostly set up in my test environment, but didn't get a chance to debug yet. Might it be a different character than a space, like maybe a tab?

In any case, it sounds like you found a bug, and since you've given me test data that reproduces it, I can fix it.

Nov 8, 2013 at 1:08 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Nov 10, 2013 at 8:48 PM

I'm definitely seeing the problem with the latest alpha, but 2013.01 seems to work fine. What version of SPServices and jQuery are you using?

Nov 10, 2013 at 9:01 PM
It was 1.8.2 I believe. I tried 10.1 too.

Nov 10, 2013 at 9:07 PM
What about SPServices? I think 2013.01 is fine. Might you have been using the latest alpha (which I'm fixing)?

Nov 10, 2013 at 9:44 PM

Honestly I don't remember. I very well may have been.


Nov 10, 2013 at 10:36 PM
I think you must have been. When you get a chance, try 2013.01 with your real data. It should work fine.