SPAutocomplete and WSS 3.0

Mar 10 at 10:15 AM
Edited Mar 10 at 10:16 AM
Hello.
Wonder if somebody can help,
I'm trying to use Autocomplete on SharePoint 2007 list. here is code that I'm using:
<script type="text/javascript" src="https://code.jquery.com/jquery-1.11.3.js"></script>
<script type="text/javascript" src="https://remote.dp-sgroup.co.uk:987/dp-systems/jquery.SPServices-2014.02.js"></script>
 <script type="text/javascript">
        $(document).ready(function() {
            $().SPServices.SPAutocomplete({
            webURL: 'https://remote.dp-sgroup.co.uk:987/CRM',
            sourceList: 'Accounts',
            sourceColumn: 'LinkTitle',
            columnName: 'Account',
            CAMLQuery: '<Contains><FieldRef Name="DPS_x0020_Company" /><Value Type="Text">DP Systems</Value></Contains>',
            CAMLQueryOptions: '<QueryOptions />',
            filterType: 'Contains',
            numChars: 0,
            ignoreCase: true,
            highlightClass: '',
            uniqueVals: false,
            slideDownSpeed: 'fast,
            processingIndicator: '<img src="_layouts/images/REFRESH.GIF" />', // NOTE: This option has been deprecated as of v0.6.0
            debug: true
        });
    });
</script>
Script is firing however no autocomplete is available.
I see no error messages or anything either.
I've managed to catch envelope that is being send and it seems to be empty:
<soap:Envelope xmlns:xsi='http://www.w3.org/2001/XMLSchema-instance' xmlns:xsd='http://www.w3.org/2001/XMLSchema' xmlns:soap='http://schemas.xmlsoap.org/soap/envelope/'><soap:Body><GetList xmlns='http://schemas.microsoft.com/sharepoint/soap/'><listName></listName></GetList></soap:Body></soap:Envelope>
I also noticed that even though I supplied webURL, $().SPServices.SPGetCurrentSite(); is still being used to determine URL and it keeps returning instead of site:987 site:987987 which is incorrect address
Any suggestions would be highly appreciated.

Leo