SPComplexToSimpleDropdown Issues?

May 11, 2011 at 2:42 AM
Edited May 11, 2011 at 2:43 AM

Some issues I had when using this function.

It works fine, but when save, for some lookups it says

"Value is not among the set of valid lookup values"

May 11, 2011 at 3:07 PM

I think this happens because of the custom master page.

Without SPComplexToSimple, it works, but sticky.

Marc can you please suggest about this?


May 11, 2011 at 3:26 PM

Keep in mind that this function is an alpha. I'm looking for help in testing, but you shouldn't be trying to use it for real!

I'll need more information on the issues you have to try to address them.


May 11, 2011 at 6:57 PM

I'm trying to figure out what is wrong.

My problem is,

I use SPCascadeDropdowns & SPComplexToSimpleDropdown

The column I use "SPComplexToSimpleDropdown", behave strangely rather ramdomly. When I select a option from that look up and try to save the error shows as "Value is not among the set of valid lookup values" , this doesn;t happen when not using SPComplexToSimpleDropdown

That what I feel like my custom master page might cause , but still I didn't find out.



May 12, 2011 at 3:34 PM

I doubt that your custom master page has anything to do with it unless you have attributes in elements there which you shouldn't have.

You'll need to do some debugging to see what's going on. Do you have the same issue if you use SPComplexToSimpleDropdown alone?


May 16, 2011 at 6:53 PM

It is happending with the cascaded dropdown only

May 16, 2011 at 6:55 PM

That's not enough information for me to help you.


May 17, 2011 at 1:36 PM

Hi Marc,

After some debugging, I found that if I have "&" in my ComplexToSimpleDropdown, I get

"Value is not among the set of valid lookup values"

I'm not sure, this is the reason, but if I remove that it works. Will do some more testing and let you know my findings.

May 17, 2011 at 1:38 PM

Interesting. Does the ampersand display correctly in the simple dropdown?


May 17, 2011 at 1:42 PM


ampersand works in the simple and complex as well, but if I use SPComplexToSimpleDropdown for any dropdown, then it gives that validation error.

Thanks for your help

May 17, 2011 at 7:35 PM

Seems, having another issue with SPComplexToSimpleDropdown

It happens when using 3level cascading, the third dropdown is SPComplexToSimpleDropdown. The value getting null/nothing even changing the value.

That means can't submit the form. "You must specify a value for this required field."

May 18, 2011 at 2:37 PM


Again, it's an alpha and I know that there are problems with it in the version that you are testing. I't's not released code yet.


May 18, 2011 at 8:10 PM

Thanks Marc

Just mentioning the issues, so that it might usefull for you.

May 20, 2011 at 3:53 PM

Try the new ALPHA: http://spservices.codeplex.com/releases/view/64390


May 24, 2011 at 1:14 PM

Thanks Marc.

It works for me.

"Value is not among the set of valid lookup values" issue is fixed with this version.


May 24, 2011 at 1:16 PM


I've tested it in many combinations of dropdowns, etc., but of course it's impossible for me to even think of all the possibilities. Let me know if you see anything funky going forward.