"GetRatingsOnUrl" not loading other users ratings

Jul 7, 2011 at 5:56 PM

I'm having some difficulty loading other users ratings for an item. It only shows the current user. It shows the exact same data as the "GetRatingOnUrl" method. I have 3 users rating an item and each one can only see their rating.

Here is a sample of the output xml from "GetRatingsOnUrl":

<soap:envelope xmlns:soap=&#8203;"http:&#8203;/&#8203;/&#8203;schemas.xmlsoap.org/&#8203;soap/&#8203;envelope/&#8203;" xmlns:xsi=&#8203;"http:&#8203;/&#8203;/&#8203;www.w3.org/&#8203;2001/&#8203;XMLSchema-instance" xmlns:xsd=&#8203;"http:&#8203;/&#8203;/&#8203;www.w3.org/&#8203;2001/&#8203;XMLSchema">&#8203;
<soap:body>&#8203;
<getratingsonurlresponse xmlns=&#8203;"http:&#8203;/&#8203;/&#8203;microsoft.com/&#8203;webservices/&#8203;SharePointPortalServer/&#8203;SocialDataService">&#8203;
<getratingsonurlresult>&#8203;
<socialratingdetail>&#8203;
<url>&#8203;
"http://site.com/subsite/_layouts/listform.aspx?PageType=4%26ListId=%7ba05765c3-b366-4400-974a-c8d331baddcb%7d%26ID=39"
</url>&#8203;
<owner>&#8203;Network\APerson&#8203;</owner>&#8203;
<lastmodifiedtime>&#8203;2011-07-07T16:46:26.137&#8203;</lastmodifiedtime>&#8203;
<title>&#8203;Teamsite Page Help&#8203;</title>&#8203;
<rating>&#8203;5&#8203;</rating>&#8203;
</socialratingdetail>&#8203;
</getratingsonurlresult>&#8203;
</getratingsonurlresponse>&#8203;
</soap:body>&#8203;
</soap:envelope>
Jul 7, 2011 at 6:24 PM

I found out the timer job was set to an hour. Had my admin change it to 10 minutes, maybe that's the issue :)

Coordinator
Jul 8, 2011 at 1:34 PM

Sounds like you are all set. Let me know if you have further questions.

M.