This project has moved and is read-only. For the latest updates, please go here.

SPCascadeDropdowns Problem When childColumn Contains A Space.

Oct 13, 2011 at 5:56 PM

I've having a problem when the childColumn has a space in the name.   Debug mode doesn't flag any errors, but the form values for both parent and child fields disappear when the display name contains a space. 

It works perfectly when there's no space, which suggests it's set up okay.

I'm using JQuery 1.5.2 and SPServices 0.6.2 and IE 7.0.   I was using JQuery 1.6.2 but it wasn't working properly when both fields were multivalued, and I found on here that using 1.5.2 would work.

Any suggestions please?  Is this a known issue, or am I doing something wrong somewhere?


Oct 14, 2011 at 12:55 AM

You need to use the StaticName of the column for relationshipListChildColumn, not the DisplayName. Spaces are encoded as _x0020_ in StaticNames, so your StaticName will be something like My_x0020_Column.


Oct 14, 2011 at 9:33 AM

Thanks for the quick reply.

It's the form ChildColumn I'm having a problem with, not the relationship list's relationshipListChildColumn.




Oct 14, 2011 at 2:51 PM
Edited Oct 23, 2011 at 4:19 AM

I just checked my test environment, and I definitely have SPCascadeDropdowns working with columns that have spaces in their names. Can you post your code?

I'm also interested in the problems you were having with IE7.


Oct 14, 2011 at 8:40 PM

Thanks.  You're right. I just tried it with another set of fields with a space and it's working fine.

I've done a bit more testing and it actually seems to be caused by the names of the columns in the form.  I'm using "Technology Type(s)" for the parent column (sorry it was actually the parent column, not child as I original said) and "Technology" for the child column, which I think is confusing it somehow. 

Here's my code:-

$().SPServices.SPCascadeDropdowns({relationshipList:"Technologies",relationshipListParentColumn:"TechnologyTypes",relationshipListChildColumn:"Title",parentColumn:"Technology Type(s)",childColumn:"Technology",debug:true});

If I change either of the display names so that "Technology" isn't in both names, it works.  Is a lookup behind the scenes confusing them because they're the same before the space?  

Oct 14, 2011 at 8:44 PM

The previous problem I had was that my multivalued form child column was losing it's values on page load when SPCascadeDropdowns was used on editform.asp

A couple of discussions on here said to use JQuery 1.5.2 instead of 1.6.2, which I did and it worked fine.

Oct 23, 2011 at 4:22 AM

I'd check the DOM to make sure that the column names are what you think in the actual page. I'm wodering if the parentheses are causing a problem.

As for the issue with multi-value columns on the EditForm, I've had several other reports of this, but haven't been able to reproduce it to date. I've got a few lists from someone and will be trying again to get to the bottom of it. Check this issue to watch any progress: