SP Services not working on site

Sep 22, 2012 at 8:39 PM

I have been using SP Services literally for years on both SP2007 and SP2010....for some reason on this one particular site that I am working on, I can't get it to read "anything".

Here is a very simple script that I tested on other SP2010 sites, just like the one I am having an issue with:

 

<script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.7.1/jquery.min.js"></script>
<script type="text/javascript" src="http://cdnjs.cloudflare.com/ajax/libs/jquery.SPServices/0.7.1a/jquery.SPServices-0.7.1a.min.js"></script>

<script type="text/javascript">
 var thisSite = $().SPServices.SPGetCurrentSite();
 alert (thisSite);
</script>

As indicated I ran through the scripts in debug mode and all get back is a blank for the SPCurrentSite.

Any help on how to begin debugging would be most welcome.

Thanks,
Todd

Sep 22, 2012 at 8:46 PM

okay...there is two hours of my life, I will never get back.   Found out it was working in FireFox, so I closed IE and restarted it, all worked!

Who knows...

Coordinator
Sep 24, 2012 at 4:52 PM

Gremlins!

M.