how spservices work - quick question please

Nov 15, 2012 at 10:59 AM

Hi All,
     Just got a quick question here.
I have been using spservices for a while now and i love it because it just works.
But lately i'm working on a project with a client and i need to use spservices for this project.
The intranet site is like an extranet but not sharepoint online i reckon service provider is hosting it for the client publicly but it seems they aren't mapping the url correctly as it a https:// site.
I don't have direct access to the server and no luck using sharepoint designer either.
So i decided to use Content Editor webpart with SPServices.
The first thing was to test if i can get the current site but no luck using


<script type="text/javascript" src="/Style%20Library/Scripts/jquery.min.js"></script>
<script type="text/javascript" src="/Style%20Library/Scripts/jquery.SPServices-0.7.2.min.js">
<script type="text/javascript" language="javascript">
$(document).ready(function() {
      var thisSite = $().SPServices.SPGetCurrentSite();



when i look at firebug it says :

Exception of type 'Microsoft.SharePoint.SoapServer.SoapServerException' was thrown
The Web application at XXXX could not be found

when i look at the web services WDSL


and look at the address location its another URL e,g http://xxx.local/_vti_bin/Webs.asmx

Am i thinking correctly and if yes what do i need to to tell them to change.


Nov 16, 2012 at 2:46 PM

It may be something in how they have set up AAM. Make sure you're hitting the site from the right URL; the one that's intended for consumption.