New 2013.01 release cannot co-exist with 0.7 release

May 9, 2013 at 5:06 PM
The couple problems I've had over the past couple days were suggested by Marc to be due to conflicts with existing code. I have just proven that conclusively.

Because I isolate my code with Crockford's module pattern, I often have several JS code chunks on a given site. When I couldn't get the simplest thing to work on one today, I went looking, and eventually found a small module that was loading the 0.7 version of SPServices. Modifying that to look for 2013.01 instantly fixed the conflict.
May 9, 2013 at 5:16 PM
My rule is to never load more than one version of any library in a page. I find that even two versions of jQuery can stomp on each other.